Comment pré-traiter vos photos de page de garde avec le logiciel gratuit GIMP

De Coetus
Aller à : navigation, rechercher

Le principe du site repose sur l'identification des livres par leur page de titre. Pour référencer un de vos livres, il n'est pas obligatoire, mais il est vivement recommandé, d'illustrer sa fiche par une photographie de sa page de garde. Toutefois, pour éviter qu'elle n'occupe trop de place sur le site, il est recommandé d'appliquer la procédure suivante sur le logiciel GIMP.

Nous indiquons ensuite où vous pouvez télécharger GIMP.

pour capter votre image[modifier]

éviter de le faire par un scanner ou une photocopieuse faisant scanner[modifier]

Vous pouvez éventuellement le faire avec un scanner si vous en disposez d'un. Toutefois, le gros inconvénient est que ça va vous imposer, pour avoir la pleine page de titre bien à plat contre le scanner face à la vitre, de casser le mors de la couverture de devant, au risque de l'endommager. C'est pourquoi nous vous recommandons d'éviter ce type de saisie, qui peut endommager votre ouvrage, or nous considérons que la communautés des bibliophiles a un devoir de transmettre aux générations suivantes les livres en bon état.

Certaines photocopieuses fonctionnent également en scanner, mais posent le même problème de cassure de la couverture du livre.

utiliser un appareil photo numérique, ou l'appareil photo de votre téléphone portable[modifier]

Il suffit d'ouvrir votre livre comme si vous alliez le lire, à la page de titre, et que quelqu'un vienne photographier la page de titre avec un appareil photo numérique (pas besoin d'un appareil très sophistiqué), voire d'un téléphone portable. Ce n'est pas grave du tout si l'image est plus grande que la page de titre, donc si la page de titre n'occupe pas toute la surface de l'écran. Par contre, essayez que la page de titre soit le plus possible parallèle aux bords de l'écran, car si elle était prise en rotation, vous auriez du mal à rattraper ça ensuite. Egalement, il est mieux que la page soit prise de face, pour éviter les déformations de la perspective.

Il vous faut ensuite transférer cette photo vers votre ordinateur, soit en sortant la carte mémoire de votre appareil pour la lire depuis le PC, soit par tout autre mécanisme préconisé par le mode d'emploi de votre appareil.


pour traiter votre image sur GIMP[modifier]

1. Lancez l'application GIMP.

2. Charger la photo. Menu fichier, choisissez "ouvrir", et sélectionnez l'image (ou les images) que vous voulez traiter. Si vous en avez choisi plusieurs, vous appliquerez successivement la procédure qui suit à chacune d'entre elles.

Si GIMP vous demande l'autorisation de convertir des choses (liées à la façon de coder les images dans le fichier informatique de votre photo), vous acceptez.

3. Sélectionner le rectangle utile de la photo.

Dans la fenêtre "boite à outils" (placée en principe en haut à gauche de votre écran si vous ne l'avez jamais déplacée), vous choisissez l'outil représenté par un rectangle gris bordé d'un cadre blanc et noir, en cliquant sur ce rectangle gris. Il s'appelle "outil de sélection rectangulaire".

Sur la photo de votre page de titre, enfoncez le bouton de clic quand le pointeur de votre souris est placé en haut à gauche de la page de titre dans la photo, et en laissant le doit enfoncé placez le curseur en bas à droite. Ceci va dessiner un rectangle qui doit arriver vers les bords de la page de titre dans la photo. C'est selon ce rectangle qu'on va découper la photo pour ne garder que la partie intéressante. Si vous voulez faire une découpe un peu plus proche du texte utile, ou un peu plus loin, il vous suffit de recommencer la procédure de clic démarrant dans un coin et se terminant dans le coin opposé.

Le rectangle sélectionné doit être toujours actif (vous voyez toujours cadre à base de tirets blancs et noirs se déplaçant au long du rectangle que vous avez dessiné à l'étape 3), sinon il faut reprendre l'étape 3. Vous voyez probablement aussi dans les coins des carrés dessinés d'un fin trait blanc, ne vous en préoccupez pas ils n'ont aucune importance pour ce qu'on va faire.

4. Découper la photo. Le rectangle sélectionné à l'étape précédente étant toujours actif, il vous suffit d'aller dans le menu Image -> Rogner selon la sélection (celui illustrée d'une lame). Et voilà, le découpage est réussi.

Cette étape de découpage a deux avantages: s'assurer qu'on ne met dans le site que la partie intéressante de la photo, et rendre la photo plus petite, donc le fichier qui la code sera plus petit, donc on occupera moins de place dans le site qui pourra ainsi accueillir plus de photos, et on utilisera moins les tuyaux d'internet quand on téléchargera la photo.

5. (étape facultative): rezoomer la photo. Pour mieux voir la suite, vous pouvez désirer agrandir la photo. Le menu à utiliser est Image -> Zoom -> Ajuster à la fenêtre. Vous pouvez aussi affiner avec Image -> Zoom-> Zoom arrière et Image -> Zoom -> Zoom avant.

6. transformer en noir et blanc (sans aucun gris). Cette étape va permettre de diminuer très fortement la taille du fichier, car au lieu de coder toutes les nuances d'ocre au noir qu'on peut trouver sur une page de livre ancien, on va simplifier la page en ne laissant que du blanc et du noir.

Pour pouvoir faire cette étape, il faut toujours que vous ayez le cadre en tirets noir et blanc se déplaçant autour de votre image (celui qu'on a créé à l'étape 3). S'il avait disparu, sélectionnez le menu Sélection -> Tout.

Alors, vous pouvez vous lancer dans l'étape 6. proprement dite en choisissant le menu Couleurs -> Seuil. Vous constatez alors deux choses:

  • l'image devient noir et blanc, mais le noir risque de s'affiner, comme s'il avait manqué d'encre sur la presse d'imprimerie,
  • une fenêtre "seuil" s'est ouverte.

En jouant sur les petits triangles noir et blanc figurant dans cette fenêtre (juste en dessous du grand rectangle qui est blanc à gauche et bleu à droite), on va pouvoir modifier l'effet noir et blanc sur la photo.

Le triangle noir permet de dire jusqu'à quel point on veut que les couleurs claires soient assimilées à du blanc. On le déplace vers la gauche ou la droite en cliquant dessus avec la souris et déplaçant la souris en gardant le bouton enfoncé. On peut le remonter jusqu'à la limite de gauche de la petite montagne que vous voyez dans la zone bleue. Vous pouvez jouer à le mettre à différente valeurs pour voir l'effet obtenu, en vérifiant bien le résultat sur l'image elle même.

Il est moins utile de jouer sur le triangle blanc (un peu caché tout à gauche), mais en le rapprochant de la montagne (en le laissant toujours à droite de la montagne), on peut éviter des piquements blancs au sein des lettres.

Quand vous êtes globalement satisfaits du résultat, vous avez terminé l'étape 6.

7. Il ne vous reste plus qu'à écrire sur votre disque dur l'image ainsi transformée. Et là c'est le menu Fichier -> Exporter qu'on va utiliser (attention, pas Fichier -> Enregistre ni Fichier -> Enregistre sous, ni même Fichier -> Enregistrer une copie, mais bien Fichier -> Exporter).

Il va falloir choisir un nom pour votre photo. Faites le terminer par .png

Pour le début du nom, pour éviter de retomber sur un nom existant déjà dans Coetus, le plus simple est que vous utilisiez le nom de la page que vous créez. Mais rien n'est imposé.

Voilà, vous avez fini, vous pouvez fermer la page avec l'image. Il n'est pas utile de sauvegarder (GIMP vous le propose au cas où vous souhaitiez pouvoir revenir à chaque étape intermédiaire).

Tout ça semble un peu compliqué, mais avec un tout petit peu d'expérience vous passerez moins de 2 minutes par photo.


pour télécharger GIMP[modifier]

GIMP est un logiciel open-source, donc gratuit. Voici sa description sous wikipedia.

Si vous êtes utilisateur ou utilisatrice d'un PC sous windows, vous pouvez télécharger ici (site en anglais), en cliquant sur la ligne "Download GIMP 2.8.0". Il se peut que le numéro ait augmenté depuis, auquel cas merci de me signaler au cas où mes instructions ci-dessus ne fonctionneraient plus.

Si vous êtes utilisateur d'un Mac, il vous faut être en version logicielle Mac X au moins, et vous trouverez ici et en anglais la façon de charger et installer GIMP pour Mac.


puis-je utiliser un autre logiciel que GIMP, ou l'image telle qu'elle sort de mon appareil photo ?[modifier]

Oui c'est bien sûr possible. Il faut juste éviter de charger des images qui fassent plus de 200k octets, car ça va vite encombrer les serveurs... Les formats jpeg, jpg, png, sont acceptés par le site.